ssWPI Updates

Discussion in 'Discussion' started by Glenn, May 14, 2017.

  1. Glenn

    Glenn Administrator

    I agree, iTunes asks to update even 2 days (it feel), reminds me of Apple, the problem is iTunes doesn't work properly if it's not the latest version, so having it updatable easily is important, let me know (once you do) if the app still lets you upgrade from it's menu or if you need to download the whole things yourself - like a caveman.
     
  2. Trouba

    Trouba Administrator Staff Member

    I'm sorry I can't be of help with your ssWPI game developments. I don't have a gamepad or anything like that but it sounds like you've made quite a few innovations to ssWPI. I'd kind of like to get the latest MGP but it's quite large and I don't know the games to make good decisions if I were to selectively download them. Mainly I don't need another distraction because I have so much stuff on my PC and I've been trying to sort it for months now. A lot of it is PDFs and audio/video talks and it is a bit overwhelming at this point. I must have been an archivist or collector in one of my previous incarnations, or if not that's what I'll be saying next time around :)

    iTunes does let me check for updates from within the program, so I'm guessing this would mean it's updatable through the app, although I won't be entirely sure until the next version. By default the program is set to check for updates automatically, so it will check without the Software Updater, I'm pretty sure. If you go to Edit->Preferences->Advanced you can change the update setting there, as well as turn off the "Send diagnostic & usage date to Apple". This can't be automated via registry as it appears all their settings are saved in encoded (and probably user-specific) files in appdata locations.
     
    Glenn likes this.
  3. Glenn

    Glenn Administrator

    Code:
    ssWPI v17.09.21.0:
    
    FIX: CPU usage was getting high just sitting on main GUI, I changed it so only user interaction would cause any redraws to occur, 0% CPU now.
    FIX: Top border on Description was erased by screenshot
    ADD: AllowDescriptionSelection=Yes This does what it says
    ADD: Right Clicking Description Selection will copy it to clipboard
    ADD: Support for adding Icons to Emulator MetaData (even using built in Editor)
    FIX: Edit Mode - Holding Alt while pressing Screenshot or Icon will repair corrupted Clipboard data (This bug has existed since I added the Edit ability and I finally found a work arround).
    CHANGE: I Enabled GDI plus to fix the above problem (ssWPI has now dropped support for pre XP OS's)
     
    Last edited: Sep 20, 2017
  4. Glenn

    Glenn Administrator

    Seems the new ssWPI doesn't work in LivePE's currently, my guess is it is the Game Controller library being added, but it may be the GDIPlus being enabled, I am not sure if anyone still uses ssWPI pre install (I don't), so I don't even know if it's worth dropping features to add the ability back?
     
  5. The Freezer

    The Freezer Lead Developer for SetupS Staff Member

    Sadly, I'm not sure how you'd even do pre-install anymore -- or what the advantages would be if you could. :(
     
  6. Spurs_dk

    Spurs_dk New Member

    When I try to run Games Launcher v17.9.21.0 and earlier versions. I get this error! It used to work.

    upload_2018-2-11_17-8-4.png

    When I set "Launcher=no" in ssWPI_Options.ini the program works fine, but not as Game Launcher.

    Does anyone knows have to get it working again?
     
  7. Glenn

    Glenn Administrator

    It may be something to do with the controller support I added (since removed), I'll upload an updated fix for it one day soon, but for now you may have to enter the x:\ppGames\ and delete the ssWPI_*.ini files (the databases), go into the ssTek or ssWPI registry key and delete all it's content. This should fix the problem. The only other thing that could cause that problem is a dud ppGame in the collection.
     
  8. Spurs_dk

    Spurs_dk New Member

    Thanks for your reply.
    I tried to delete the database, but I could not find anything in the ssTek or ssWPI registry key .... So it did not work. But I found out that, if I changed "AddNonppGamesToLauncher=YES" to "=NO" then it worked.
    So maybe I have a game in my collection that does not work...
     
    Glenn likes this.

Share This Page